At present the books attached to Credits are not showing. I marked a number of Credits for recycling as I thought they were redundant before I realized what was happening. I have taken note of the URLs and changed the titles of the "duplicates" to something else so they won't be inadvertently recycled. Additionally, I am able to access the History of the Credits I marked as duplicates, but when I click on the version data I receive the following error message:

Server Error
"'NoneType' object has no attribute 'getitem'"

This error has been logged and we will look into it.

LOL - I think you broke it.

That thought did run through my mind.

Think the breaking was all our fault. This should be fixed now. Apologies for the inconvenience but thanks for the heads up.

Working nicely. Many thanks.

It seems that I only binned 4 credits thinking that they were not attached to Books. The problem is if I click on the oldest version of the history I am still getting the message that I cited above. Until this is resolved I can't reinstate the Credits.

The affected Credits are:

https://www.bookogs.com/credit/103503-do-not-edit

https://www.bookogs.com/credit/40187-do-not-edit

https://www.bookogs.com/credit/55468-do-not-edit

https://www.bookogs.com/credit/198914-do-not-edit

kalli my last comment was a question directed to the staff. Because of the glitch where the Books appended to the Credits disappeared, I mistakenly edited four Credits thinking they were redundant, retitling them as Duplicates in preparation for recycling.

I still can't access the first version of the history of the four Credits that I have listed as I receive the following message:

Server Error
"'NoneType' object has no attribute 'getitem'"

This error has been logged and we will look into it.

Until this has been resolved I have no idea what the original titles of the four Credits were.

hey Anaideia, sorry for the late reply. There seems to be something weird going on with the version history for credits (version one seems to be missing and therefore trying to view a diff between one and two will fail with the error you mentioned above).

I've reported this error to our developers and have fixed the titles you mentioned by looking them up through in the admin back end. Thanks for your patience and data diligence.

Thanks for the update.

Another small bug. This entry keeps appearing when using the search term 'Duplicate':

https://www.bookogs.com/credit/284466-duplicate

However, you can't use it, but its beginning to irritate me.

It should be gone now. ;-)

Excellent. The saying give a man a fish and you feed him for one day, give him a fishing rod and you feed him for life, springs to mind. Just how did you do that?

I just did an empty edit on the renamed entry:
https://www.bookogs.com/credit/284466-mary-swainson

There was a similar case in Filmogs not so long ago where the updated title of a film hadn't fully gone through: it was showing on the Film page, but the rest of the system was still using the old name. Editing the Film page fixed the situation so I figured the same might work here too.

Thanks!

mirva I still don't know how you were able to determine the new name of the duplicate, so that you could type the url and then conduct an 'empty edit' on the new credit.

Why I ask is that there is another one stuck in the list of duplicates: https://www.bookogs.com/credit/201626-duplicate

Now, if I had that tool in my repertoire I wouldn't need to bother you. Thanks.

Look up the entry number (201626), that never changes. It's Martin Page (2). :)

Got it now! Thanks.

Looks like nothing is getting indexed at the moment...

mirva I reported a similar problem yesterday directly to the staff. The reply that I received stated "...the worker that does the indexing, adding new or updated entries to the search, crashed...".

The problem that I had yesterday was rectified shortly after, but as you noted the fault is back.

I do hope that worker wasn't injured.

I hope so too... A small change of plans, then. I'll clear out some duplicate companies instead. :)

Hey, we did indeed run into some problems with the indexing worker (the day after international worker day none the less). It should be fixed but currently we are being plagued by a lot of spam. Indexing should be caught up soon. Thanks for letting us know and for your patience.

I've been watching the spammer for the last few hours now. It's getting very tedious watching it grow and not being able to anything about it. Maybe more forum admins? Or at least block posters who post more than two posts per minute.

agreed xceque, we are looking into adding more features to avoid and get rid of spam. There are already some things in place, but these spammers are a crafty bunch.

It's back.

And again.

I've been watching the spammer for the last few hours now.

Tap him or her on the shoulder and tell them to get a life.

They've been banished to the recycle bin of ogs.
/dev/null'd into oblivion.
So there's no shoulder, never mind a life.

Ooh, it's back and it's brought some friends.

Although it's not actually spam, is it. No-one is reading those messages and thinking 'there's some products I'd love to buy'. No-one is being endeared towards them. It's just vandalism.

Sentinel One to Hercules. Astrea has gone nuts again.

We are trying to monitor this and delete as spam gets added. Longer term we hope to have more robust spam defenses soon. Thanks for the heads up everyone.

@xceque: The point of this sort of spam afaict is mostly to get links back to the websites that the spammer is promoting. Those sort of links count towards their ranking in search engines. This also makes it more important to try to get rid of the spam early, before search engines crawl this sort of content and the spammers actually get what they want.

Thanks for the info kalli. Didn't think of that since there are only plain text web addresses, no actual hyperlinks.
Is there any system for alerting admins directly to problem users or posts for quick response?
A 'report this user' button?
I've been replying in this thread under the assumption that every time I or anyone else does you (at least) would get a message, since you'd be subscribed by virtue of having posted yourself, and that would draw your attention and you'd spot another batch.

And they're back... 10 pages in the forum and counting. :/

Yup, this round had just kicked off when I last posted.

At least the following accounts posting:
https://www.bookogs.com/users/suxiza1007
https://www.bookogs.com/users/suxiza1008
https://www.bookogs.com/users/ahfmsek00
https://www.bookogs.com/users/madggyw
https://www.bookogs.com/users/dasdadsad
https://www.bookogs.com/users/wod718wod

They've been adding books more recently, rather than just posting in the forum. It's when they start editing books that we'll have a major problem since there's no way to easily revert yet. At least, not for us regular users.

Yeah, they are doing both. And don't give them bad ideas... :P

The bots can't read yet... I hope...   :o

keeps fingers crossed

We really need a "report user" button or something...

Indeed! I said exactly that mere hours before. We also need someone on the other end of it.

Let's hope that the devs have the matter in hand. I expect there are spam detection systems/plugins out there that can be employed beyond simple if-then-else coding to catch suspicious behaviour.

A nice idea would be flagging users as spammers instead of deleting them, tagging spam as spam instead of deleting it right away and only showing things marked as spam to users flagged as spam. Then they can spam away thinking they're having a right old time but with no effect to the rest of us, and will take them longer before realizing they need a new account.
Bit development intensive though. Hey, I can dream.

<Those sort of links count towards their ranking in search engines.

I have always wondered why people bother with this sort of behaviour, so now I know. One more step in my path to enlightenment.

Whoops! My quote arrow must have been backwards. I have just woken up.

Back again.

Someone needs to revive the indexing worker again... Been waiting since Saturday for renamed entries to get indexed. :/

Someone needs to revive the indexing worker again

That would be helpful, plus stop sending me notifications for edits that occurred prior to my involvement with books and credits. My personal email inbox is filling up with rubbish.

Still waiting...

Good news mirva, it seems the indexer is up and running again. My email inbox had only two notifications this morning, so maybe my comment was heeded also. Now we just have to get rid of the Korean spammer and life can return to normal.

Hmmmm. Then either it's working slowly its way through, or then there has been an additional glitch with the credits I added on Saturday because they still haven't been indexed.

Yeah, it would be nice to get rid of the spammers, and I do understand that blocking them is a high priority.

Ok, it seems that I might have to go and do an empty edit on all of them... just hoping I can find them all. :P

just hoping I can find them all

I know the feeling.

mirva I believe I have found two of your edits:

https://www.bookogs.com/credit/326799-canongate-books-ltd
https://www.bookogs.com/credit/192967-cannongate-books-ltd

I can't locate the modified credits.

Yeah, I had trouble locating them too, some were easier to find than others... Luckily if I couldn't find them through Google search, I could always find them in my contributions. A little bit tedious but I found them all. :)

Apologies xceque and Anaideia. In my overeagerness to clear up spammers I accidentally sent the two of you to spam purgatory (temporarily)

I have restored your user accounts to their former state and re-added all the submissions, but let me know if you see any inconsistencies. I fear the last couple of hours of additions might be inconsistent due to our backup structure and that about 5 documents may have be lost in total (including some replies from this thread)

Again I'm terribly sorry. I have revised my spam script to be more easily recoverable and shall try to measure twice and cut once in the future.

re. updates being missing in the search results. I have reindexed all books from the last week in case any updates or additions got lost in the shuffle. Will do the same for credits. Thanks for your patience.

The three book submissions that I made yesterday afternoon have disappeared, my book collection has been reset to zero and my reading list includes every book submission that I have ever made.

I had to re-set my collection/list sharing settings, but apart from that my account looks ok now. I hadn't done any editing in a while.
That'll teach me to make jokes in Korean.

xceque you're lucky.

@Anaideia. Again very sorry about this.

my book collection has been reset to zero and my reading list includes every book submission that I have ever made.

I just had a better look at those lists, should be restored to their prior state now. Let me know if they still look off to you.

The three book submissions that I made yesterday afternoon have disappeared

I'm afraid those are totally gone.

Those lists look a lot better and I suppose can resubmit the three books. Thanks.

I have reindexed all books from the last week in case any updates or additions got lost in the shuffle. Will do the same for credits.

Thanks. :)

Entries with parentheses are missing from the drop down again when adding a new book.

Bookogs has now been bombarded by spammers for the past five days. How much longer is this going to occur?

@kalli The three books which I submitted that were deleted during the spam purge are still showing up in the database, however if I click on them I get a 404 message. The books in question are:

'Flashman and the Mountain of Light' by George MacDonald Fraser: https://www.bookogs.com/search?q=flashman

'The Castlemaine Murders' by Kerry Greenwood which I resubmitted and both copies are shown here: https://www.bookogs.com/search?q=kerry%20greenwood

'A Long Way From Home' by Peter Carey: https://www.bookogs.com/search?q=a%20long%20way%20from%20home

Do they still exist or not?

@Anaideia ah actually hadn't considered that the entries would still be in the search service, I have restored them to the db from the info in there. Some detail might be missing, maybe check them out. Thanks for the heads up and apologies again for nuking those entries.

https://www.bookogs.com/book/345904-a-long-way-from-home
https://www.bookogs.com/book/345815-flashman-and-the-mountain-of-light

@kalli almost there. With the https://www.bookogs.com/book/345904-a-long-way-from-home submission there are four credits that appear in the search service but are not active in the database:

https://www.bookogs.com/credit/345910-steve-waters-2
https://www.bookogs.com/credit/345905-glen-curnow
https://www.bookogs.com/credit/345906-john-leonard-curnow
https://www.bookogs.com/credit/88942-michael-lionstar

Hopefully, you can restore these as well. Thanks.

Fixed, thanks for your diligence Anaideia.

No, it is not fixed. I have no idea what is going on. The four credits will not form hyperlinks in the submission and the book credit is not shown as an attribution for any of the four. I have tried all sorts of work arounds to no avail.

my bad, but think it should be good now.

Thanks kalli, I reckon we are back to normal.

Now the two restored submissions have twins in the database.

https://www.bookogs.com/search?q=A%20Long%20Way%20From%20Home
https://www.bookogs.com/search?q=Flashman%20and%20the%20Mountain%20of%20Light

It looks the doppelgängers have left the building.

It looks like the doppelgängers have left the building.

Fixed, thanks again Anaideia.

Now occasionally when I click the "Edit this Book" button, the data doesn't load, all I get is the title. It seems to be random, but happens sometimes several times in a row.

Me too. Also when "Add one like this". F5 helps.

Yep! Same here.

I should add that my fix is to hit the page refresh which then loads the data correctly.

Yeah, refresh fixes the issue, though sometimes I have to refresh the page several times for the data to show up.

Drop down is a bit ropey again, only lists the first 10 credits. Plus if credit includes '&' or a comma etc. it doesn't appear, eg.

Simon & Schuster, Inc - https://www.bookogs.com/credit/25867-simon-schuster-inc

Thanks for the heads up on the submission form problems. That should have been fixed now.

@westpier: We are aware of the symbols being problematic in the search. Hope to investigate soon. Thanks for the ffedbacl.

Thanks, likewise accents above letters can be a problem eg. if submitter doesn't know its André Deutsch rather than Andre Deutsch, as André will not show up if submitter types Andre.

@westpier: The ampersand bug should be fixed now. We are aware that handling accented characters (unicode case folding) isn't optimal, hope to address that soon

A delayed thank you for fixing the ampersand bug. :-)

Another thing: when I try editing on my phone, the corner bubble covers the "Save" button - I always have to change to landscape mode. Not a big deal, just mildly annoying. :P

thanks for the heads up mirva, will pass that on to the developers.

Hi everyone
Did anyone notice that recent additions is not updated when someone add a book or credit?

I notice that book credits are also being offered when typing a credit in a submission. It certainly is the case if you are typing The Beatles.

I notice that book credits are also being offered when typing a credit in a submission. It certainly is the case if you are typing The Beatles.

This has been fixed, thanks for the feedback.

Trying to change following entry to 'Duplicate' but for some reason when I press the 'save' button nothing happens:

https://www.bookogs.com/credit/240316-hackette-book-group-inc

Can someone else try it, thanks.

I can't edit anything
A warning system appears:
"Our spam systems flagged this action as spam"
Anyone else?

@Vipasser: Are you still getting that error? We have been tweaking our spam systems a bit today because of an onslaught of spam.

Is it for all kinds of edits / submissions? Or just very minor edits?

Yes, I'm still getting that message: "Our spam systems flagged this action as spam" when I try to add a new book. In the meanwhile the only one I could add it is https://www.bookogs.com/book/385005-la-coartada-perfecta

Can't edit a Wikipage. Click save button and page just hangs, not even an error message.

I had problems with the save button sometimes last week, but as the problem went away I thought it had been fixed. Looks like I was wrong.

It was totally random though, sometimes the button was working and sometimes not. If it didn't work, most of the time I had to go back and redo the edit.

mirva I thought you might have banned me from adding magazines to the Wiki page :)

I have attempted three times without luck. It might be something to do with the latest spam filters.

Just in case I get run over by a bus these are the three magazines I am trying to add to the Music section of https://www.bookogs.com/wiki/magazines-on-bookogs

disco revue (/credit/385136-disco-revue)
Les Rockers (/credit/385152-les-rockers)
POP 2000 (/credit/384719-pop-2000)

Until the Wiki page editing problem is fixed, here are some more magazine titles.

Men's Interest (if that is a euphemism for straight male porn):
Chobix (/credit/385426-chobix)
QX (/credit/385417-qx)
Newlook (/credit/385410-newlook)
Front (/credit/385406-front)
Ché (/credit/385400-che)
Hot Video (/credit/379704-hot-video)

Music:
Atem (/credit/252727-atem)
Rock & Folk (/credit/385319-rock-folk)
rock'n'roll musique (/credit/385026-rocknroll-musique)
Sonic Seducer (/credit/385382-sonic-seducer)
Vive Le Rock! (/credit/385393-vive-le-rock)

Film, Cinema & Television:
Schokkend Nieuws (/credit/385359-schokkend-nieuws)

???
Bizarre (/credit/379668-bizarre) - described as an alternative magazine
Sinical Magazine (/credit/379673-sinical-magazine) - alternative/fetish modeling & photography magazine

if that is a euphemism for straight male porn

I think they are sometimes included in the "Men's Interest" section, but most of the time adult/porn magazines have their own section. I would consider doing it here too.

mirva I thought you might have banned me from adding magazines to the Wiki page :)

Hehe... Even if I could do something like that, I would never ban anyone from improving the database. I'm not that mean. :P

Thanks mirva, it seems the edit function has been restored. I will create an Adult/Porn section as you suggest. I will list Sinical Magazine in Photography. I am still undecided about where to put Bizarre. Any suggestions?

I'd suggest Culture for Bizarre magazine.

The wikipedia page states, "Bizarre covered alternative culture through interviews with counterculture personages, and articles about the Occult, LGBT culture and drug, fetish, and other subcultures. It also reviewed the work of avant-garde directors, musicians, authors, and visual artists—and of those who have a cult following."

https://en.wikipedia.org/wiki/Bizarre_(magazine)

Bizarre is a difficult one to categorize...

As above, Culture would be a good suggestion...
It was always with all the other Men's magazines in the shops...
The cover used to say "Don't buy if you're easily offended. Contains gore, girls, sex and violence".

Thanks for the replies. I have added Bizarre to Culture.

I just went to access the Wiki pages and I am getting a 404 error. One way to get rid of the guidelines.

I have sent the staff a message via the dialogue bubble on this topic.

For some reason I can't access the book submission History. I click on the button and it just doesn't respond.

I am now able to access the History but it is slow to respond.

Is the slight incredibly slow at the moment (and last night) or is it just my crappy internet connection? Judging by the amount of new submissions it might just be me.

Getting this error:
Error 502 Ray ID: 42e5bf1baa023494 • 2018-06-21 10:21:08 UTC
Bad gateway

I am constantly getting a 502 as well, which I believe is a problem with the Bookogs server and nothing to do with your internet.

It doesn't last for long but I have lost some data as a result.

I am also having problems loading pages as they tend to hang for awhile.

There is something very wrong with the system at the moment. I am constantly receiving either a 502 (bad gateway) or 522 (timed out) error which I can trace to the Bookogs server. On several occasions I have lost data as a result. I hope this is fixed soon as it is rather annoying.

@westpier and Anaideia are you still having those problems?

I have stopped getting the 502 and 522 errors, but I am still finding some pages are very slow to load.

No longer getting that error, and seems back to normal speed for me, thanks.

I am finding that pages won't load completely; the title loads but the rest of the data won't. This was an intermittent fault a couple of weeks ago but is now the norm. I rectify it in Google Chrome by clicking on the refresh page button. Previously, this worked first time but now I have to refresh several times before the page loads properly (my record is 10 tries). It does make multiple editing a trying experience.

It is working like grease lightning at present! Not sure if that is due to intervention or luck.

It's still happening, it's especially bad when adding images to books. It is a bit random, sometimes you can edit hours without getting a single problem, and then suddenly you have refresh the page 10 times every time.

It could be like a relay race. I hope the baton is not returned to me anytime soon as it is still working magnificently (touch wood).

Anybody else having problems with adding more than one Date?
Adding one is fine, but for the second one only the description field is available...

Exactly the same problem here! If you try to save with just the description field, this error message appears:

Date-Date: u'' does not match '^\d{4}(-\d{2})?(-\d{2})?$'

Same problem. I have found that most of the date fields have disappeared from submissions. I believe this is due to maintenance being done to the Works pages. I have reported the bug directly to the staff.

OK, thanks for the info, hopefully when this has been fixed I can add the missing Dates to the recent submission where only one Date could be added.

This date problem is becoming a definite nuisance.

It seems that any dates that do not conform to a strict yyyy-mm-dd format or contain extraneous data are blocked from the system. At present, I (and many others) are adding Works, and it is not possible to add any of the books that have a date problem. It means I have to keep a list of books that are affected by this problem, in the hope that it is resolved sometime in the future.

I do hope it is resolved soon because my list is getting longer and longer.

In the meantime, I am adding the extra dates (the 1st date field is not affected) in the Notes section.

I have also added Date(s) that can't be added otherwise in the Notes, but it would be better if the issue would be solved, otherwise the list of additions in retrospect might for some grow out of porportion.
I have not had any problem (at least I don't thinks so...) in adding Books to Works with Date issues - as long as I don't make any changes to the Date fields...

I am adding the extra dates (the 1st date field is not affected) in the Notes section.

I just hope users transfer the data to the correct fields when the matter is resolved.

I have not had any problem (at least I don't thinks so...)

If you had then you would have found that the error blocks the ability to save any new edits, i.e. you wouldn't have been able to complete the Works edit. Unless... I won't go there as I don't want to give users ideas.

The Date issue appears to have been fixed as (at least I can) add more than one Date once again.

That makes two of us. Thank you staff.

I don't know if anyone has brought this up, but it seems that it's no longer allowed to enter text or multiple years in the date field. I understand the reasoning behind it, but what to do when something else needs to be fixed - should I just delete the extra data from the fields?

For example: https://www.bookogs.com/book/347471-the-handmaids-tale

Ι'm afraid the extra info has to be moved to Notes.

Yep. It is strictly yyyy-mm-dd. When I have encountered extraneous information in the dates I have been recording it in Notes. I reckon a free text facility would be handy in this situation.

Ok - thanks. :-)

I wish there were images, so I could reflect exactly what is printed on the book. But I guess it's more important to be able to edit books, so I will leave a request to update them if needed.

hey everyone, apologies for tardiness in responses here and thanks for the heads up on some of the bugs or problems.

Regarding the validation of the dates, the field should allow yyyy, yyyy-mm or yyyy-mm-dd format. In my opinion things that aren't in that format don't belong in that field but in the type dropdown or in notes. Maybe each date entry needs a type field (drop down) and an optional note (free text) field?

We mean to keep improving on the submission form, so all of this feedback is appreciated.

Reprint dates are a problem as these can sometimes be quite lengthy. Some users have recorded them as strings on the one line, which obviously is no longer supported. My solution is to list the entire set in Notes and add the last reprint date to Dates, as this is the most relevant in the book submission.

I do think a free text field would be handy to record such things like publisher names and countries alongside dates.

Just a few minutes ago something strange happened:

I added this book:

https://www.bookogs.com/book/413632-ciencia-ficcion-seleccion-35

and then

https://www.bookogs.com/book/413633-ciencia-ficcion-seleccion-36

the same image was uploaded by someone in credits and this book:

https://www.bookogs.com/credit/413634-evelyn-e-emith
https://www.bookogs.com/credit/413635-r-delany
https://www.bookogs.com/credit/413637-phyllis-einstein
https://www.bookogs.com/book/413646-continentes-hundidos-tierras-del-futuro
https://www.bookogs.com/credit/413647-sebastian-fontrodona-boada

I realized, thought it was me, because before this happened my browser was uploading and finally failed after some minutes
I disabled all those images manually and then added

https://www.bookogs.com/book/413648-cosecha-roja

and the same image was uploaded atomatically, and after I disabled and uploaded the right one

Is this a strange bug?

Again the same image uploaded by system:
https://www.bookogs.com/book/413656-diario-de-las-estrellas-viajes-y-memorias

And I thought I was just having a bad day!

I have reported the image problem directly to the staff.

Thanks mate. I decided to have a break :D

The system has gone haywire, I'm out of here.

Just happened to me as well, got the same image (now removed:

https://www.bookogs.com/book/413669-black-flag-no-135

The image I uploaded here:
https://www.bookogs.com/credit/413620-les-newsom

…has started appearing on other profiles.

Tell me about it.

hey everyone, thanks for the heads up. We are aware of this problem, hope to have a fix out soon. Thanks for your patience.

Yes and the credits also go crazy, "edited by ..." no user

At this moment the image of Howard Waldrop
https://www.bookogs.com/credit/104297-howard-waldrop
appears on
https://www.bookogs.com/credit/37580-rowohlt-taschenbuch-verlag
and that is a credit with no history (not edited).

The pictures of dear old Howard Waldrop popping up everywhere add a nice creepy feeling to the whole proceedings.

my picture is everywhere
https://www.bookogs.com/book/413632-ciencia-ficcion-seleccion-35

The pictures of dear old Howard Waldrop popping up everywhere add a nice creepy feeling to the whole proceedings.

At least it makes a change from the Cheshire Cat grin of Les Newsom and the cover of Ciennca ficcion seleccion 35.

We have just released a fix for the image issues. Apologies for the inconvenience. Submissions with these broken images can be fixed by going into "edit images" and marking the wrong images as disabled.

Let us know if you see this problem rear its head again.

I've added/edited a work, but none of the data appears:

https://www.bookogs.com/work/425638-die-braut-des-prinzen

If I open the edit form, all the infos are shown and in the history everything is visible too.

Yikes BadMoon. I thought you had suffered a one off bug, but I have just encountered the same problem with other credits.

This problem with the works page should be fixed now, sorry for the trouble everyone.

There is another problem at present which I assumed was related to the Works credits bug, but unfortunately this hasn't been resolved.

The Original Language and Original Language Title is not showing in book credits. Here is an example: https://www.bookogs.com/book/142577-duizend-schitterende-zonnen

The Original Language and Original Language Title is not showing in book credits.

This has been fixed, thanks for the heads up!

When trying to add an image to a book, I get:

Server Error
"Tried to leave "div" but something closed it already"
This error has been logged and we will look into it.

thanks for reporting @kwulf, fixed it.

Pictures not currently uploading for me, I press 'upload' and just get a blank bar and nothing happens (using Opera in Windows). Plus quite a few 'Bad Gateway' messages.

eg. Error 502 Ray ID: 44c065c03a43358a • 2018-08-18 00:52:23 UTC

I am also experiencing Bad Gateway errors and slow response times. Several times as I have been editing, the page has locked up and will not respond. In these situations I have had no choice but to kill the page and lose my edit. The diagnostic traces the problem to a server error.

https://shop.bookogs.com/catalogue/the-summons_14066/

Even though the book listing has an image, the sales listing for it does not show it.

Still getting Bad Gateway Error 502, making submitting a bore. Plus worried it will cancel out a lengthy submission.

I am having trouble loading book credits using the V2 editor, if there is an error in the submission, e.g. date format, superseded credit role, etc.

The only way I can load the page is use the V1 editor and make the correction to the non-compliant data. Once the data has been amended I can then use the V2 editor as normal.

There is another bug this time with the Works credits.

When I delete a name variation from a Works credit and submit, the book page shows the Works credit as *. I then have to re-edit the book, delete the Works credit and type it, select it from the menu and then resubmit the book. The Works credit shows normally.

Further to my comment about the V2 editor. I have found that date formats that include zeros for the dd component are preventing the page loading. I have never known 00 in dd to register as a highlighted error in the V2 editor, so I find this surprising.

Yes V2 will not let you continue until you've corrected the date or old superceded credit but surely this is what should happen? Also why would you need 00 in the date credits? Unless I've missed something in what you're trying to do.

Sorry westpier, I will try that again.

If I try to edit a book submission which has a pre-existing error (shown as a red highlight when you open the page) using the V2 editor, the page will not load. I click on 'Edit this Book' and all I get is a blank page. The only way I can successfully load the submission data is to use the V1 editor, make my edit, correct the pre-existing errors and then submit. Once this is complete then I have found the V2 editor works fine (but at this stage I don't care because I don't need it anymore).

Also why would you need 00 in the date credits?

I agree, however some users format the date in that fashion. It has never been a problem up until yesterday.

I have received word from the staff that they are working on a solution.

OK, I see what you mean now, it was ok for me a few days ago but haven't come up an 'error' one in the last few days. Though I do get a blank white screen as it waits to load, goes after about 6 seconds.

goes after about 6 seconds

I'm not known for my patience. That could be the problem!

LOL - I've just got the blank screen which won't go, damn you Sexton.

Ha, ha my little wax figure of you sitting at a computer is starting to work. Wait until I start sticking pins in it.

There was a time when only two formats were accepted: YYYY and YYYY-MM-DD. The YYYY-MM format is a recent addition, and is not even mentioned in the guidelines.

"This is the exact or approximate date of the public release / launch of an object. The date can be listed as the year, month and year, or the specific day, or left empty. For an exact date, enter in the format "YYYY-MM-DD" (02-Sept 1997 would be 1997-09-02). For an approximate date you may enter only the year (in four-digit format, YYYY) or year and month with "00" for the day (YYYY-MM-00). Approximate release dates or conflicting information can be placed in the notes field. (8.1.1.)'

Interesting. The problem is the site developers must have forgotten that advice, or at least the system has rejected it. If the dd component has 00 then I can't load the page using the V2 editor.

I have noticed a change when I try to change the image order in a credit. Previously I could pick an image up and position it, and it would stay there. Now it is like picking up a piece of fly paper. I move the image into position and it sticks to my cursor. Is there a knack to this that I don't know about?

I mentioned this in another Forum topic but I think it needs repeating.

Something has been altered and strings of dates are being displayed in odd ways. For example, "1963, 1967, 1968" was shown in the V1 editor as "1967-19-68". I also struck a situation where descriptions had disappeared and what was displayed was "1967-" instead of "1967 [USA]".

If you are making edits and notice these sorts of anomalies then I suggest that the book credit should be opened in a new tab to view the actual data before making any changes.

hey everyone, sorry about the confusion on dates. The 00 month format is indeed not permitted anymore, nor is anything that doesn't adhere to the YYYY/YYYY-MM/YYYY-MM-DD format (for example those old list of years you mention SextonBlake). Let us know if you run into any trouble with the format, we can try to fix this.

Apologies for the inconvenience, there's always going to be some trouble moving to a stricter input format. But we think eventually those restrictions make sense and lead to better data quality.

Thanks kalli. I am still having problems moving images in a credit. As I explained I pick up an image with my cursor and move it to a new position, but it won't let go. Previously I could pick the image up and once in position it would stay put. Am I doing something wrong or is this a bug?

It's happening to me too both in credit images and book images, so I assume it's a bug.

hmm, we have not changed anything regarding images lately (though we have some changes to itcoming up). You could try force refreshing (cmd/ctrl+shift+r in most browsers) on the image page. Which browsers are you using?

I'm using Google Chrome. This has only happened recently and I don't think I have changed my behaviour. It occurs on every credit so it is not a page issue. The image simply won't disengage from the cursor once it has been selected and positioned.

I just fired up Safari and it seems to be working fine. I then went back to Google and it is nightmarish. So it seems to be a Google Chrome issue. Coincidentally, I noticed some subtle changes in the way Google Chrome functions about 7 days ago. In particular when I copy and paste urls, that might be the problem.

I'm using Google Chrome as well. I rarely need to change the order of images so it has not been a huge issue.

I rarely need to change the order of images so it has not been a huge issue

I am seriously considering giving up the habit

I just worked out a quick fix.

Disable the images you wish to succeed the primary and then re-enable the images in the preferred order. It saves a lot of mucking around.

Ok, thanks for letting us know. I haven't been able to replicate, but multiple reports confirm this bug.

We have changes to the image form coming out soon, in the meantime thanks for your patience!

Interested in seeing what you guys have come up with. :)

Another thing... Occasionally when I go back and adjust a credit/credit role, the fields below overlap the dropdown. I'm not quite sure how to explain it, but here's a screenshot:
https://i.imgur.com/CSNTHAo.png

When it happens, I just usually type in enough to get the credit/role on the top of the list so it's easy enough to bypass.

When i try to add
dtv (https://www.bookogs.com/credit/19173-dtv)
as an imprint to
https://www.bookogs.com/book/447885-der-name-der-rose
it does not show up in list.
I can still add it when i click "add new credit"

this seems to happen with some credits with short names more often

GruenerTee, I agree it is a nuisance and the subject was discussed here: https://www.bookogs.com/forum/421825-existing-subjects-dont-appear-in-drop-down

For some time now when I click on the last page of the Browsing Book and Credit lists I receive the message: "Sorry something went wrong. Please try again later"

Not the first (or even the second) time that bug appears:
https://www.bookogs.com/forum/180584-bug-when-browsing-books-by-pages-internal-server-error

Again only the first 250 pages are available.

Thanks mirva, I knew this had been discussed and fixed before, but I couldn't remember the name of the topic. It certainly has been an ongoing problem.

this has been fixed (again), hopefully a bit more of a robust fix this time. Thanks everyone.

I hope you used extra strength glue, together with some thick elastic bands.

I've just tried to add a book through "add one like this", because an amount of photo credits but was unable to reorder. the credits. So I've decided to complete the entries and reorder afterwards. Unfortunately, pressing Preview. led to "Nothing to preview" and moving back erased all the entries I've made, despite those of the preloaded book.

I've thought, those datas should be remembered since the last update?!
And Reorder Credits is still not working.

I've thought, those datas should be remembered since the last update?!

Currently the form only remembers data when adding a new entry (not when editing or using "add one like this", we are looking into adding it for those modes).

moving back erased all the entries I've made, despite those of the preloaded book.

Pressing "back" in the preview mode should take you back to the edit form and if you pressed back in your browser a warning should have popped up that you had unsaved data?

And Reorder Credits is still not working.

You can not reorder credits at all? It does seem to work for me. Which browser / os are you using?

if you pressed back in your browser a warning should have popped up that you had unsaved data?

I have not seen this to happen, and I just tried it, and at least in Chrome there's no warning when you press the back button.

I have not seen this to happen, and I just tried it, and at least in Chrome there's no warning when you press the back button.

Hmm, so that ought to work on edits (on a new sub it should save the data and show it to you when you open add/book again).

so that ought to work on edits

Oh ok, it does work on edits. I thought it would also work on new submissions... my mistake. :)

You can not reorder credits at all? It does seem to work for me. Which browser / os are you using?
I couldn't yesterday, today it's working. (Mozilla Firefox).

I just created several Work credits and I can't find them using the search engine. If I didn't have a record of the urls I would assume they didn't exist at all (but they do).

They could be waiting in a queue so I will take a break for awhile!

They finally arrived. Must have been a log jamb.

Not sure if this has been discussed elsewhere but on does clicking on the older 'version' work for anyone? I just get an error message. I had a profile hijack so can't see what i originally wrote.

I think it has, but way back. For some reason the first version of the history is unavailable. The staff are aware of the problem.

The system seems to be slowing down again. Downloading pages and submitting data is taking longer than usual (at least from my location).

Is that a new 'drop down menu'? As it doesn't appear to work when you click on the name.

Yes, the new search menu should display images alongside the search result if they're available, but something's going wrong. Fixing it now!

Should be working as it should again now. Hope it improves your searching!

Do we have problems with the dropdown?
I've created the following duplicate (accidentally, of course), because the existing credit wasn't offered, athough it is spelled the same way!
https://www.bookogs.com/credit/409291-beatrice-dalle
https://www.bookogs.com/credit/483504-beatrice-dalle

hey BadMoon, we haven't noticed any problems, did you run into this issue again? Merged that dupe.

Actually not.

I have ran into some issues with accented names in the past, but it has been a while.

The only problem I've noticed with the drop down recently is it disappears after you 'rick-click' a link on it which doesn't happen on Discogs. Sometimes I want to look at a variety of links / entries. Only a minor irritant though.

The only problem I've noticed with the drop down recently is it disappears after you 'rick-click' a link on it which doesn't happen on Discogs.

Yes, we are aware of this annoyance. We hope to address that and some other small tweaks with credits rendering in the form soon!

Login or Register to post a reply to this topic.